• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale


maximus00

Problems Picking Up Radio Stations?

2 posts in this topic

i have a 2004 1.4 duratec and the radios been fine up until a few weeks ago. it wont find any stations at all , but sometimes works for a certain period of time maybe 15 miles and then cuts out and all you get is static. i have taken the radio out and made sure everything is plugged in and all seems ok .Also i took the in-car light out and checked the connection to the aerial was ok and that was fine too. if u manually tune it i can pick up some radio but not clear enough ???? am baffled

Wonder if any-one had any other ideas it could be ?

Share this post


Link to post
Share on other sites
 

Have you checked the threaded bolt where the antenna screws onto the external mount?

If there is corrosion there you will get a weak signal which automatic tuning will miss.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now