Jump to content


Aircon Issues.... Help Please!!

  • Please log in to reply
1 reply to this topic

#1 dragonuk2000



  • New Member
  • Pip
  • 5 posts
  • Name: Matt
  • Ford Model: Mondeo 2.0 Zetec Estate
  • Year: 2008
  • Location: Lancashire

Posted 29 July 2012 - 04:46 PM

Hi all I have had my 2008 Mondeo 2.0 duratec estate since Jan with no issues a few weeks back the aircon started to blow warm, I listened out for the compressor and looked out for the usual engine dip upon activation there is a distinct click so the compressor clutch is coming on and the engine does dip a little so off I went to get it regassed. It came back all fully gassed with a clean leak free report however it still wasn't getting cold. I have checked to see if the engine fan comes on when I put the aircon on and it does as you would expect., its been 3 weeks after the regas and the compressor still comes in when the button is pushed so I dont think it has a coolant leak (the condenser was changed 18months ago according to the ford receipts that came with the motor)

Im at a total loss as im no aircon engineer and I dont really want to take it to a specialist before I do some research first, if you guys on here have any ideas please help me out :(

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 btmaldon


    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,592 posts
  • Name: Bruce
  • Ford Model: KA Edge, BMW 320i Coupe M Sport
  • Year: 2015
  • Location: Essex

Posted 30 July 2012 - 07:30 PM

Have a look around the internet to see if there is a reset proceedure for the system. I used to have a Mk3 Ghia with the climate control and that could be reset by pressing and holding several buttons at the same time. It would then run through a sequence of events while it reset itself.

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users