Jump to content


Photo

Street Ka Convertibe - Battery Problems


  • Please log in to reply
1 reply to this topic

#1 tunalou

tunalou

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: StreetKa
  • Location: Staffordshire

Posted 04 August 2012 - 01:00 PM

I really could do with some help - I have had a new battery and a new alternator, but the battery still drains. I have not used the car that much over the past 3 weeks, but I don't think this should be happening - any ideas ?



Caz

Have something to contribute?

Sign in or register to start a topic...

#2 PaulKa

PaulKa

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: StreetKa
  • Location: Berwickshire

Posted 30 January 2013 - 03:27 AM

Hi Caz,
The following assumes you have a basic knowledge of electrics and you will need a multimeter.
The battery could be poor but a good way to test is;-
Ensure the battery is well charged by going on a long run with the lights, electrics, etc. minimised. Then once parked-up, measure the battery voltage - it should be 12.7V or more, depending upon how long it is left.
- Disconnect the battery negative (-ve). BEFORE doing so, check that you have the Radio Key Code because the radio will need this before it works again.
Leave the car for a day or so.
Measure the battery voltage again, if it remained the same as before, it suggests the battery is not losing charge. Hook-up the battery again and check that the engine starts. If it won't then this suggests the battery has lost it's charge.
If the battery is seeming okay then the problem probably lies with the car electrics.
Next, ensure everything is switched off on the car electrics. Keep the battery disconnected and using the Ammeter on the multimeter, connect the battery negative to the black negative lead by passing the current through the multimeter leads. The multimeter will indicate if there is any current flowing from the battery.
If current is indicated when all the electrics are off, then there is a problem somewhere on the electrical system.
To narrow down the search, you can open the fuse box (above the accelerator pedal) and you will see lots of fuses.
Ideally you need to position your ammeter where you can see it or get another person to help by taking readings.
Next, remove one fuse at a time and see if the current loss stops. If there is no change, put the fuse back in the same position and move on to the next fuse. Do the same test and work through each fuse in turn ENSURING that each fuse goes back in its original location.
Once you remove a fuse and the current drops to zero, this will indicate which circuit is at fault - and will help narrow the search.
This information will help tracing the origin of the fault, but depending upon the nature, you may still need professional assistance, but time can be saved by following this process.
Hope this helps,
PaulKa


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users