Jump to content


Show
Photo

Sun Roof Problem


  • Please log in to reply
2 replies to this topic

#1 The Gardener

The Gardener

    Member

  • New Member
  • PipPip
  • 18 posts
  • Ford Model: mondeo mk3 petrol estate 1.8 (x reg)
  • Location:

Posted 18 February 2009 - 08:16 PM

Hi All!

The problem i have with the sunroof on my mondeo is that when you press the switch all i get is lots of loud clicking and no movement from the sunroof?

Any Ideas? :blink:

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,464 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 19 February 2009 - 03:49 PM

it could be that one of the plastic drive cogs has worn the follow link will show you the location of the motor
http://www.mirez.co.uk/Sunroof.htm

#3 The Gardener

The Gardener

    Member

  • New Member
  • PipPip
  • 18 posts
  • Ford Model: mondeo mk3 petrol estate 1.8 (x reg)
  • Location:

Posted 19 February 2009 - 07:42 PM

it could be that one of the plastic drive cogs has worn the follow link will show you the location of the motor
http://www.mirez.co.uk/Sunroof.htm



Many thanks!

I shall check motor asap.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users