• Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts


ascowie

Sat Nav Problems

5 posts in this topic

Hello Can someone help me

I connected the sat nav up, and switched on my engine, plugged the sat nav in and there is no power getting to it,

Any ideas what could be wrong

My father said it could be the fuse, but only have my licence for 1 month I have not a clue where the fuses are.

Share this post


Link to post
Share on other sites
 

More info please. What satnav unit is it? Was there power to the unit before you switched the engine on? are you powering it from the 12v cigar lighter socket?

Have you tried powering something else from the same socket? If so and thats not working, then it is likely just a fuse.

Share this post


Link to post
Share on other sites

My father said it could be the fuse, but only have my licence for 1 month I have not a clue where the fuses are.

Lucky you didn't get asked any "show me where the fuses are" type questions on your test then.

Might be worth genning up on this info before you drive any further.

How is the sat nav wired? Hard wired to the car? Who installed it?

Share this post


Link to post
Share on other sites

Fuses behind glove box.I blew mine a while back and only knew when I plugged my sat nav in.

Share this post


Link to post
Share on other sites

Got it sorted, there is 2 fuses on the board for the cigerette lighter

Thanks

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now