Jump to content


Show
Photo

Misfire


  • Please log in to reply
33 replies to this topic

#31 Fordtastic

Fordtastic

    Member

  • New Member
  • PipPip
  • 26 posts
  • Ford Model: 1.8 Zetec Mondeo mk 3
  • Year: 2003
  • Location: Kent

Posted 18 October 2012 - 06:54 PM

Thanks for the web link mate,I'll give it a try.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#32 ppeter7

ppeter7

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 317 posts
  • Name: peter
  • Ford Model: mondeo 1.8/ mondeo 2.0 zetec
  • Year: 2001
  • Location: Devon

Posted 18 October 2012 - 06:58 PM

ok buddy no probs,hope all is good

#33 Fordtastic

Fordtastic

    Member

  • New Member
  • PipPip
  • 26 posts
  • Ford Model: 1.8 Zetec Mondeo mk 3
  • Year: 2003
  • Location: Kent

Posted 19 October 2012 - 01:29 PM

Just put the old Mondie up for sale.Still starts first time,just got a slightly uneven tickover.Shame cos it's still a nice car apart from that.

#34 ppeter7

ppeter7

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 317 posts
  • Name: peter
  • Ford Model: mondeo 1.8/ mondeo 2.0 zetec
  • Year: 2001
  • Location: Devon

Posted 19 October 2012 - 03:29 PM

sunds funny but have you checked egr valve ok or the flap on throttle body ok easy fix egr valve just undo the 4 screws on electric top part and press plunger to see if it gose down smoothly if not could need clean.throttle body flap wd40 around cable area then put some on clean cloth and wipe inside around the flap worth a shot and its free to lol :P


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users