• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members


mcclaffs

2009 Mondeo 1.8 Tdci No Bluetooth Option On Radio

16 posts in this topic

Hi all

Newbie here. Just bought a 58 plate 2009 mondeo which has the green and red buttons on the head unit for the phone. The indicator stalk also has phone controls and a voice button at the end. My problem is there is no option in the menu to turn the bluetooth on or off. The last option in the advanced menu is the "No Vid". Any help here on this issue would be greatly appreciated.

Thanks

Share this post


Link to post
Share on other sites
 

hey mate click on this link http://www.etis.ford.com/vehicleRegSelector.do;jsessionid=C5AD05B0CEADF72CFD5F8FC101F817C6.eccvas506

put your reg in and then on next page on the right is an arrow this will bring up all the options that are on your car if you have any problems just give me your reg and ill have look. liam

Share this post


Link to post
Share on other sites

hey mate click on this link http://www.etis.ford...817C6.eccvas506

put your reg in and then on next page on the right is an arrow this will bring up all the options that are on your car if you have any problems just give me your reg and ill have look. liam

Hi Liam

The ETIS Site is great. The following is in the list of added extras " BT/VC Phone Interface Only". Any idea what this means or why there is no bluetooth option on the menu

Thanks

Share this post


Link to post
Share on other sites

i've had quick look round google lol do you have in the glove box or arm rest the usb aux sockets??

Share this post


Link to post
Share on other sites

There is an aux port in glove box, don't see a USB. The reg is bt58frf if you need it

Share this post


Link to post
Share on other sites

right had another look around and it seems you should have it and apparently you need to reset it i've copyed this from another site

Ok first remove the drivers lower footwell trim (centre console side ) this is held in with 1 phillips screw , once removed look under the heater box and you will see a black nokia module . to remove this just pull it down ward (its held by a metal tang),

make sure the ignition is off and remove the multiplug off the bluetooth module then put the ignition on and leave it for 5-10 minutes , then turn the ignition off and re-connect the multiplug and re-fit the module and trim and re-test the bluetooth system by pairing your phone to it . job done

IMG_7622.jpg

IMG_7623.jpg

Hope this helps mate i know on ford focus its behind glove box so if its not under heater box try that and if its not there i dunno lol might be quick trip to ford. liam

Share this post


Link to post
Share on other sites

Hi Liam

The latest update is.......................I removed the panel but could not locate any nokia module. Its a much tighter space than the the one in the photo. I could't figure out how to remove the glove box so i disconnected the battery hoping to reboot the system. After 20 mins I reconnected the battery. Everything works as it was except now in the advanced menu there is a vechicle id option which was not there before. Is this related? Any id what id I put in here, or how to input it even.

Thanks

Share this post


Link to post
Share on other sites

am not sure how the glove box comes out in yours i know in mine you open the lid and you will see 3 tabs on the bottom inside of the glove box and then there are 2 above on either side where did you buy the car from was it ford dealer?

Share this post


Link to post
Share on other sites

am not sure how the glove box comes out in yours i know in mine you open the lid and you will see 3 tabs on the bottom inside of the glove box and then there are 2 above on either side where did you buy the car from was it ford dealer?

No the car was previously owned by Lex Autolease. Its driving me crazy at this stage

Share this post


Link to post
Share on other sites

the only other place is the moduale can be is behind the glove box but it comes out totally differnt to a focus had quick google search i found one but as i have no idea what the insides of the glove box look like it made no sense to me

http://www.talkford.com/topic/96283-glovebox/

Share this post


Link to post
Share on other sites

Latest update is I removed the glove box.

Located the nokia module.

Disconnected the module.

Turned on ignition for 10 minutes .

Turned off ignition and Reconnected module.

No change

I took some pics of the module. Is there any way to test at home to see if module is dead?

Share this post


Link to post
Share on other sites

Maybe your Radio has been changed for an older model and is not BT compatable

Share this post


Link to post
Share on other sites

sounds like trip to ford

Share this post


Link to post
Share on other sites

Any idea if the Vechicle ID section of the advanced menu has anything to do with it or where I would get this Vechicle ID. It came blank after i disconnected the battery

Share this post


Link to post
Share on other sites

no idea mate maybe might be worth just trip to ford can only ask and see what they say. liam

Share this post


Link to post
Share on other sites

I believe that is so you can enter your registration and postcode to enable recovery if the radio is stolen.

Used to be like that in the sub menu's on the 6000CD anyway.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now