• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Join Premium & Save
      Join Premium & Save


spud1962

Escort Mk6 Overheating -- Cooling Fan Not Working!

Recommended Posts

Please can anyone help?

Just lost the use of radiator cooling fan on my mk6 1.8 16v escort ghia, causing the engine to overheat.bigcry.gif

I think i have discovered the correct sensor/switch connected to a coolant pipe underneath

a short right angled air intake pipe which i have temporarily removed

Does anyone know how to test or bypass the temperature switch at the source?

How should I test if the fan itself is not kaput?

When disconnected from the switch, The loom end has 4 wires. The terminals are marked 1 to 5 with no connection to terminal 2. if i bridge the switch at this point, surely this will activate the fan?

Not sure how to discover which of the connections when bridged will allow the fan to operate.

Note: If I disconnect the switch and run the engine - the fan does not operate either, but I'm not

sure if it should anyway ?

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now