Jump to content


Photo

Gem Trouble? How Much Will It Cost...


  • Please log in to reply
3 replies to this topic

#1 Aboyner

Aboyner

    Settling In Well

  • New Member
  • PipPipPip
  • 51 posts
  • Name: Aaron
  • Ford Model: Focus
  • Year: 2005
  • Location: Dublin

Posted 30 August 2012 - 08:57 PM

ok so here's my story..

I have two lights that keep coming on on my dash, "low washer fluid level" in a yellow/orange light and "low brake fluid" in red and also the handbrake sign seems to come with this. Obviously neither of these are low thats the problem!

At first I thought maybe there's something wrong with the sensors... my mate who works in ford had a look and there was fuses kinda loose that he pushed back in and he thought maybe that might of been what was wrong but the lights came back on(they come on and off whenever they want but they stay on most of the time) so he said the computer might need to be plugged in and just turn them off.

So today he brought the ford computer home with him plugged it into my car and was not able to turn off the errors. He then said its coming up that there is a problem with the Gem.

Does anyone know how much one of these are to get changed? Or ever have this sort of problem?My cars a 2005 1.6zetec if that matters.

Im going back to college soon and really dont have the money to be spending loads on my car.

Thanks in Advance guys.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Lenny

Lenny

    Retired Moderator

  • FOC Supporters
  • 9,779 posts
  • Name: Leonard
  • Ford Model: Focus ZetecS
  • Year: 2010
  • Location: Ireland
Contributor

Posted 30 August 2012 - 09:21 PM

ok so here's my story..

I have two lights that keep coming on on my dash, "low washer fluid level" in a yellow/orange light and "low brake fluid" in red and also the handbrake sign seems to come with this. Obviously neither of these are low thats the problem!

At first I thought maybe there's something wrong with the sensors... my mate who works in ford had a look and there was fuses kinda loose that he pushed back in and he thought maybe that might of been what was wrong but the lights came back on(they come on and off whenever they want but they stay on most of the time) so he said the computer might need to be plugged in and just turn them off.

So today he brought the ford computer home with him plugged it into my car and was not able to turn off the errors. He then said its coming up that there is a problem with the Gem.

Does anyone know how much one of these are to get changed? Or ever have this sort of problem?My cars a 2005 1.6zetec if that matters.

Im going back to college soon and really dont have the money to be spending loads on my car.

Thanks in Advance guys.



Perhaps check the earth points around the engine bay to ensure they are not loose.
A new gem could be as much as 500 euro mate,
You could try the modified elm327 guide preee has done on here will cost you less than 30 euro and will allow you to reset the gem aswell as switch off the fluid sensor.

#3 Aboyner

Aboyner

    Settling In Well

  • New Member
  • PipPipPip
  • 51 posts
  • Name: Aaron
  • Ford Model: Focus
  • Year: 2005
  • Location: Dublin

Posted 31 August 2012 - 06:17 PM

I'll have a look Lenny thanks.
Ye he said to me that it could be about 500. That's bad news anyway :-(

#4 artscot79

artscot79

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 7,228 posts
  • Name: arthur
  • Ford Model: focus mk2 ti-vct
  • Year: 2006
  • Location: Fife

Posted 31 August 2012 - 06:49 PM

give these guys a call they can repair youre original 01634 687222 bba reman is the name


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users