Jump to content


Show
Photo

fault code PO420 bank 1


  • Please log in to reply
2 replies to this topic

#1 getfocusworking

getfocusworking

    Settling In Well

  • New Member
  • PipPipPip
  • 34 posts
  • Ford Model: focus zetec 1.6
  • Location:

Posted 21 February 2009 - 05:35 PM

I have a 1.6 Zetec Focus 2001.

Fault code po420 has shown which is listed in the book as catalyst system efficiency below threshold bank 1.

Have reset code a couple of times but shows again.

Can anybody tell me is it best to renew the catalytic converter first or the first and second oxygen ( lamda ) sensors first.

Thanks for any help.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 SierraYankee99

SierraYankee99

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 859 posts
  • Ford Model: Ford
  • Location:

Posted 21 February 2009 - 05:40 PM

I'd suggest first getting technical advice from Ford. I'd suggest its just Lamda sensors rather than the cat itself.

#3 getfocusworking

getfocusworking

    Settling In Well

  • New Member
  • PipPipPip
  • 34 posts
  • Ford Model: focus zetec 1.6
  • Location:

Posted 22 February 2009 - 02:51 PM

I'd suggest first getting technical advice from Ford. I'd suggest its just Lamda sensors rather than the cat itself.


Thanks for the advice.

Have taken the two sensors out today and found one had rust on the end of the sensor.

Have cleaned it off but if it lights up again will replace it.

Many thanks.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users