Jump to content


Photo

Need Advice


  • Please log in to reply
1 reply to this topic

#1 Jason 'Tweek' Batty

Jason 'Tweek' Batty

    Settling In Well

  • Members via FB
  • PipPipPip
  • 99 posts
  • Ford Model: Mondeo
  • Year: 2008
  • Location: Lancashire

Posted 13 September 2012 - 03:42 PM

Well I bought a beat 675 from a forum member a few weeks back. after having problems getting the power on, finding out it had a break on a power board, and fixing it. Then to discover there was no sound coming from the head unit. After taking it to an audio specialist in Manchester he checked the unit out and said the soundchip was more than likely blown and it would not be worth fixing.

I had a dispute open in paypal but because I had the unit repaired, to hopefully get the power back on and not have to send it back and get a refund etc, they closed it and told me I could not claim because it had been repaired????

So I have contacted the forum member numerous times via PM and told him the situation. I want to send the unit back and get a refund but I have had no reply. I am out of pocket £80 for the unit plus £30 for an auto electrician to test the unit and my car.

I needs advice on what to do next if anyone can help please.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 DanGull

DanGull

    Area Rep: Midlands (Despite owning a Seat)

  • FOC Supporters
  • 2,229 posts
  • Ford Model: Formerly a Mk7 Fiesta Titanium 1.6 TiVCT now a Seat Leon FR+ 2.0TDI 170
  • Year: 2014
  • Location:
Contributor

Posted 14 September 2012 - 10:04 AM

Jason - contact me by PM with more information including the other member involved and I'll see what I can do to help.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users