• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts


Fiesta Mk7 Clutch Problem?

5 posts in this topic


I've got a 59 plate Zetec S (Mk7) which has now done 36,000 miles, and recently I have noticed the gears are sometimes a bit stiff/notchy, especially in third where is sometimes decides to make a small grinding noise.

Anyway last night I pulled away and went to put it into second and it wouldn't engage so I stopped and couldn't get it into any gear. I kept pressing on the clutch and finally got into 2nd and manged to pull away in 2nd, then it was all back to being just a bit stiff.

It did go into Ford the other day and they said I could need a new clutch :(!

Any help/ideas would be much appreciated!

Thanks, Jack!

Share this post

Link to post
Share on other sites

You would have to really punish a clutch to wear it out in only 36k.

Before it got like that, did you notice a particularly high bite point?

Share this post

Link to post
Share on other sites

No the biting point felt pretty normal to me.. I can still drive it now only a little stiff sometimes. Ford said something to me about the clutch doesn't suppress properly or something I think?

Share this post

Link to post
Share on other sites

I have the same problem with the 59 plate fiesta edge I have, have you noticed that the gears are okaish when the engine is cold, I took it too ford and basically they said there was nothing wrong with it, I have only done 15000 miles, I have found the solution, the gearbox is basically the same as the previous model this was a known fault, the gear linkage is connected to a spigot with a plastic moveable band that after time, starts too stick, apparently the replacement of this arm and plastic bit is the best solution, other peeps have just greased up the arm and slightly bored out the plastic bit and this helps and works, I have not done this yet, but you could try under warranty if you still have it, it wont be your clutch, its just a known fault that ford dont want to know about, I wont be buying another ford after this, because every ford I have had has been a mechanical arsehole including this piece of s/*t im driving now!

Share this post

Link to post
Share on other sites

Ok thanks for that, I have heard/seen from a lot of people that its the gear linkage.

Warrenry expires the end of this month so I'm going to be taking it down to ford this week and having a moan again!

Thanks for your help!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now