Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


bubbleboy

Electricity problem

4 posts in this topic

Hello,

my 2000 ghia estate stalls the first time I start it pretty much every time unless I rev it (sometimes even then).

It also stalls sometimes when I come to a stop or slow down.

Any ideas?

The plugs and leads have been changed but it hasn't helped.

Cheers.

B.

Share this post


Link to post
Share on other sites
 

Hello,

my 2000 ghia estate stalls the first time I start it pretty much every time unless I rev it (sometimes even then).

It also stalls sometimes when I come to a stop or slow down.

Any ideas?

The plugs and leads have been changed but it hasn't helped.

Cheers.

B.

sounds very much like the idle control valve to me. might be worth taking it off and giving it a clean befoe replacing it though

Share this post


Link to post
Share on other sites

I'd second that assuming its a petrol of course.

Edit, re-reading the post confirms it must be a petrol cos its got plugs and leads.....

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now