Jump to content


Show
Photo

Hi


  • Please log in to reply
1 reply to this topic

#1 merchantofdoom

merchantofdoom

    Member

  • Budding Enthusiast
  • PipPip
  • 10 posts
  • Name: Nathan
  • Ford Model: Focus
  • Year: 2008
  • Location: Yorkshire

Posted 18 October 2012 - 09:43 AM

Hi all. Having recently purchased a cheap fiesta as a work hack I've noticed a few problems. When trying to wash the windscreen the water barely reaches the screen and the rear doesn't work at all. I can hear the motor when pulling the stalk on so don't think it's this. Is this a common fault and can anyone help with how to check if that's the fault?

Thanks in advance.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Lenny

Lenny

    Retired Moderator

  • FOC Supporters
  • 8,789 posts
  • Name: Leonard
  • Ford Model: Focus ZetecS
  • Year: 2010
  • Location: Ireland
Contributor

Posted 18 October 2012 - 11:04 AM

Hi all. Having recently purchased a cheap fiesta as a work hack I've noticed a few problems. When trying to wash the windscreen the water barely reaches the screen and the rear doesn't work at all. I can hear the motor when pulling the stalk on so don't think it's this. Is this a common fault and can anyone help with how to check if that's the fault?

Thanks in advance.

Welcome to the forum,
Try putting high flow of water in the bottle like the garden hose for ten minutes to flush out contaminants and some viniger to break down lime.
Then unplug the pipes front the rear of the jets, and press the washer.
If you get good flow then you need new jets.
But if flow is bad then the seal in the pump is passing resulting in low pressure.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users