Jump to content


!!! Focus 2.0 Ghia 1999 {Advise Please}

  • Please log in to reply
1 reply to this topic

#1 AutyBear



  • New Member
  • Pip
  • 5 posts
  • Ford Model: focus
  • Year: 1999
  • Location: Yorkshire

Posted 23 October 2012 - 07:26 PM

Hi all , i got a 1999 focus 2.0 when i 1st come to start the car i have to rev it abit , its as tho the Auto choke doesnt work if its got 1 ? i have no idea ? the car runs fine but just its just on start up , if i dont rev it , it will cut out ? any1 got any ideas please ?

also i just bought the car about 1 month ago , so no idea about the timing belt , how much should i be paying for the job doing ? I'm in wakefield area so if any1 knows of a good garage , glad to hear about it Posted Image

Thx Guys + Girlz Posted Image

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 artscot79


    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 8,165 posts
  • Name: arthur
  • Ford Model: focus mk2 ti-vct
  • Year: 2006
  • Location: Fife

Posted 23 October 2012 - 08:20 PM

timing belt around 70k miles youre well overdue on a 99 car prices are around 230-300 depending on garage ide have the starting issue checked at the garage too it sounds like the idle control valve has gone

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users