Jump to content


Show
Photo

Xr3I Running Issues


  • Please log in to reply
1 reply to this topic

#1 DH xr3i

DH xr3i

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: Xr3i
  • Location: Lancashire

Posted 24 October 2012 - 04:38 PM

I have recently bought an 87 xr3i as a bit of a project car. The issue I am having is it intermittently loses power. When full throttle it seems to run fine but when you stop or release revs it shakes, rattles loses power and then cuts out (seems to me like fuel isn't getting through to the engine or something. When having this issue it also back fires and sounds like someone his fired a gun! Had this issue previously but taking it out for a run and one massive back fire seemed to solve it? Wondering if anyone has experienced this problem before? I was thinking it might be crap sat in the bottom of the tank going through to the engine or something to do with the fuel filter?? Any help would be appreciated!

Cheers Dan

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 vinnyvangough

vinnyvangough

    Ford Enthusiast

  • Moderator
  • 2,325 posts
  • Name: Steve
  • Ford Model: 2003 Focus TDCi, Escort Mk6 RS2000, Mk2
  • Year: 2003
  • Location: Devon

Posted 06 November 2012 - 08:29 PM

Bit strange.
Majority of the time back-firing is a sign of over fuelling


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users