• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Heater *mostly* Blowing Cold

2 posts in this topic

during the summer I noticed a gurgling bubbling noise when shutting the car off, the air con is constantly on and works well. now the cold weather has kicked in I've noticed the heating not working. I put it to HI and it still blows cold with or without air-con on. i set the fans to max and then changed from LO through to HI, and i can hear the tone of the fans change, so whatever motors are in there are working. then what i did was turn the fans off, then after a minute turn them on and the air is warm, max fans slowly cools the air until cold again though, its as if there is not enough hot water going through and the blower is taking the heat out. i also noticed if i go for a quick thrash in low gears and high revs, the heat comes back for a bit. my guess is that somehow air has got around the system and is lingering in the heater area, high revs maybe pushes enough water through it. is this a known issue with a known fix?

Share this post

Link to post
Share on other sites

I'd say that your heater matrix has packed up.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now