Jump to content


Photo
- - - - -

2004 Ford Fiesta Non Starting


  • Please log in to reply
4 replies to this topic

#1 nathstevenson

nathstevenson

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: fiesta
  • Location: Midlothian

Posted 27 October 2012 - 02:49 PM

Hi Guys new forum member here

I bought a 54 plate ford fiesta last friday (just over a week ago). I drove it most days but then when I went out on thursday morning the car unlocked via the central locking but when I attempted to start the car I got no dashboard lights and no reaction from the engine.

Its a ford fiesta 1.25 lx just in case that makes any difference

I got out a repair truck who attached a battery pack and this made no difference, the repair guy suggested it might be an immobiliser problem. The car has now been towed to the garage I bought it from but it is a general garage and not a Ford one (the specialise in VW) and if it is an immobiliser problem they say they can't do anything about it.

I also tried both keys and it made no difference

I am wondering if any could advise on what they think it could be and how it could be fixed?

Thanks Nathan

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 digidash

digidash

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 101 posts
  • Ford Model: cougar
  • Year: 2014
  • Location:

Posted 27 October 2012 - 06:25 PM

i doubt immo fault as you would still have dash lights. does anything else work (lights/radio/horn/wipers) i would guess if lights work ign relay/fuse or switch. if no lights main earth or lives, regards steve

#3 nathstevenson

nathstevenson

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: fiesta
  • Location: Midlothian

Posted 27 October 2012 - 06:42 PM

Lights and Radio were still working, if it was a relay/fuse which fuse would it be? I know there are 2 fuse boxes the one in the glove box and the one in the engine bay, any clues as to which one it might be?

Thanks Nathan

#4 sambooka

sambooka

    Sam Oglesby

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 1,034 posts
  • Name: sam
  • Ford Model: mk7 fiesta zetec s
  • Year: 2009
  • Location: Lincolnshire

Posted 28 October 2012 - 01:05 AM

Lights and Radio were still working, if it was a relay/fuse which fuse would it be? I know there are 2 fuse boxes the one in the glove box and the one in the engine bay, any clues as to which one it might be?

Thanks Nathan

It should be marked on the lid of the fuse box which fuse/ relay it is ignition should be engine bay box but not sure as I've never been in the glove box one

#5 Magenta

Magenta

    Serial Poster

  • Budding Enthusiast
  • PipPipPipPip
  • 465 posts
  • Name: Alan
  • Ford Model: Fiesta Mk7 Titanium 1.4 Auto - Marello
  • Year: 2009
  • Location: Worcestershire

Posted 29 October 2012 - 08:31 AM

It does sound like an electrical problem to me. Are the fuses not detailed in the handbook ? Assuming the battery isn't flat are the battery connections and battery leads sound ?


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users