Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


nathstevenson

2004 Ford Fiesta Non Starting

5 posts in this topic

Hi Guys new forum member here

I bought a 54 plate ford fiesta last friday (just over a week ago). I drove it most days but then when I went out on thursday morning the car unlocked via the central locking but when I attempted to start the car I got no dashboard lights and no reaction from the engine.

Its a ford fiesta 1.25 lx just in case that makes any difference

I got out a repair truck who attached a battery pack and this made no difference, the repair guy suggested it might be an immobiliser problem. The car has now been towed to the garage I bought it from but it is a general garage and not a Ford one (the specialise in VW) and if it is an immobiliser problem they say they can't do anything about it.

I also tried both keys and it made no difference

I am wondering if any could advise on what they think it could be and how it could be fixed?

Thanks Nathan

Share this post


Link to post
Share on other sites
 

i doubt immo fault as you would still have dash lights. does anything else work (lights/radio/horn/wipers) i would guess if lights work ign relay/fuse or switch. if no lights main earth or lives, regards steve

Share this post


Link to post
Share on other sites

Lights and Radio were still working, if it was a relay/fuse which fuse would it be? I know there are 2 fuse boxes the one in the glove box and the one in the engine bay, any clues as to which one it might be?

Thanks Nathan

Share this post


Link to post
Share on other sites

Lights and Radio were still working, if it was a relay/fuse which fuse would it be? I know there are 2 fuse boxes the one in the glove box and the one in the engine bay, any clues as to which one it might be?

Thanks Nathan

It should be marked on the lid of the fuse box which fuse/ relay it is ignition should be engine bay box but not sure as I've never been in the glove box one

Share this post


Link to post
Share on other sites

It does sound like an electrical problem to me. Are the fuses not detailed in the handbook ? Assuming the battery isn't flat are the battery connections and battery leads sound ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now