• Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


jaycharger

Battery Drain

1 post in this topic

Not sure if this is the section to post this,

I have a 2007 Focus 1.6tdci style bought from a Ford stealership March this year. After a month had a starting problem it went back to Ford who found a fault with a module that powered down the dash. They replaced the module & put me a new battery in, everything was fine untill this weekend, Sat morning it would not turn over but the electrics worked, I got it started with jump lead & went to my local garage who do all my repairs on my other car. They tested the battery & said it was all good there must be a drain somehwere. Any ideas what the problem could be, do you think Ford should should do the work under warranty as the previous work should be under warranty still?

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now