Jump to content


Show
Photo
- - - - -

Squeaky Gear Stick


  • Please log in to reply
10 replies to this topic

#1 denwhit

denwhit

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: fiesta titanium
  • Location: Greater London

Posted 19 November 2012 - 11:21 AM

HI, anyone got any ideas. a sort of dry bearing sort of sound when i move the gear stick either when the clutch is engaged or not. driving me mad and not due a service for 8 months. bit of oil or grease required? if so , how do i remove the gaiter and surround without damage? cheers.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 PPKing

PPKing

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 120 posts
  • Name: Paul
  • Ford Model: Fiesta Zetec S
  • Year: 2010
  • Location: Essex

Posted 19 November 2012 - 07:19 PM

Hi mate, interesting one.

I have the same problem with mine, makes a little squeak sound, most often from 3rd to 4th and vice versa. My car has just had a full service with ford and passed without any ambers so puzzled on how to correct!

#3 Stoney871

Stoney871

    Resident Peacekeeper

  • Super Mod
  • 14,014 posts
  • Name: Clive
  • Ford Model: Focus mk2 1.8 TDCI Sport
  • Year: 2007
  • Location: Devon
Contributor

Posted 19 November 2012 - 07:49 PM

I'd reckon the linkage just need greasing.

#4 BobbyBCFC

BobbyBCFC

    Settling In Well

  • New Member
  • PipPipPip
  • 45 posts
  • Ford Model: Fiesta Style 59
  • Location: Gloucestershire

Posted 10 January 2013 - 09:26 AM

Did anyone suss this one? I am having the same issue.

#5 Girlracer

Girlracer

    Settling In Well

  • New Member
  • PipPipPip
  • 32 posts
  • Ford Model: fiesta zetec s
  • Year: 2010
  • Location: Warwickshire

Posted 10 January 2013 - 07:30 PM

Hi Guys i had the same problem with my zs they greased mine up but soon came back. ive ended up having my gear
cables changed now i have no noise mine was in 1st and 3rd
gear x

#6 White_ZS_TDCI

White_ZS_TDCI

    Settling In Well

  • New Member
  • PipPipPip
  • 48 posts
  • Name: Craig
  • Ford Model: Fiesta Zetec S TDCI
  • Year: 2010
  • Location: Yorkshire

Posted 11 January 2013 - 03:29 PM

I'm having the same problem, when changing from 1st to 2nd and 3rd to 4th.

Looks like we all have 2010 Fiestas too, bit of a coinsidence.

I'll be sure not to get pied off with a re grease at my next service and ask for new gear cables.

Should this be covered under warranty?

#7 Girlracer

Girlracer

    Settling In Well

  • New Member
  • PipPipPip
  • 32 posts
  • Ford Model: fiesta zetec s
  • Year: 2010
  • Location: Warwickshire

Posted 11 January 2013 - 10:18 PM

yea bud mine was wouldnt wait till next service to be honest go and get it sorted now. yep mine is a 10 plate you had any other probs with yrs x

#8 White_ZS_TDCI

White_ZS_TDCI

    Settling In Well

  • New Member
  • PipPipPip
  • 48 posts
  • Name: Craig
  • Ford Model: Fiesta Zetec S TDCI
  • Year: 2010
  • Location: Yorkshire

Posted 11 January 2013 - 10:36 PM

Got my service end of feb so might as well wait.

Only real problem is the passenger door seal which keeps coming off and a clunk on steering column on full lock. Both fixed at last service. But the seal is hanging off again!

How about you mate? my warranty runs out in march so wanting to get anything done while I can.

#9 Girlracer

Girlracer

    Settling In Well

  • New Member
  • PipPipPip
  • 32 posts
  • Ford Model: fiesta zetec s
  • Year: 2010
  • Location: Warwickshire

Posted 11 January 2013 - 11:05 PM

ive had quite a few bits done on mine i like a perfect car though im ott lol paid enough want it right lol. had roll bar bushes changed last week and top strut thing changed from creaky steerin bushes was cause of bangin over speed bumps. all the door seals are crap many people moan. had discs and pads changed they were warped !Removed! nightmate hey x

#10 White_ZS_TDCI

White_ZS_TDCI

    Settling In Well

  • New Member
  • PipPipPip
  • 48 posts
  • Name: Craig
  • Ford Model: Fiesta Zetec S TDCI
  • Year: 2010
  • Location: Yorkshire

Posted 11 January 2013 - 11:12 PM

I'm exactly the same. Bugs me if things aren't right. Might get them bits looked at then before warranty runs out. Brakes seem rubbish! so i'll get them checked for sure! Cheers for the info.

#11 Girlracer

Girlracer

    Settling In Well

  • New Member
  • PipPipPip
  • 32 posts
  • Ford Model: fiesta zetec s
  • Year: 2010
  • Location: Warwickshire

Posted 11 January 2013 - 11:56 PM

i had loads of trouble with my brakes nearly killed myself there was loads of travel in the pedal i had the abs module changed and as i say discs and pads too been brilliant since stop the car great i had all judderin on steerin wheel when brakin did my head in. x

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users