Jump to content


Show
Photo

Focus Tdci 2003 Struggels To Start When It Has Been Wet Weather


  • Please log in to reply
2 replies to this topic

#1 Keasty25

Keasty25

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Focus
  • Location: Cornwall

Posted 19 November 2012 - 06:41 PM

Hi all,
Im new to this forum so if this isnt the right area to post this i apologise.
Im having a problem recently with my Focus Tdci 2003 starting when it has been raining or damp weather, it turns over but struggles to fire its like im trying to start an old tractor engine, and the glow plug light flashes, im not sure if there is water somehow getting into the engine bay, i have had it serviced about 2 months ago when they replaced the cabin filter it broke the scuttle panel seal thus leading to a wet passanger footwell which i have sorted now and no water is getting in that way, some people said it may the Egr valve but that have been cleaned.
I thought i would to and get some advice from you guys before i take it to the garage and get stung with a huge bill
Has anyone had this problem? If so what solved it?

Many thanks In advance Chris

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Keasty25

Keasty25

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Focus
  • Location: Cornwall

Posted 19 November 2012 - 07:21 PM

anybody????

#3 Stoney871

Stoney871

    Resident Peacekeeper

  • Super Mod
  • 14,769 posts
  • Name: Clive
  • Ford Model: Focus mk2 1.8 TDCI Sport
  • Year: 2007
  • Location: Devon
Contributor

Posted 19 November 2012 - 07:48 PM

Check the engine wiring for wet connectors or damage.



Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users