Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
getaway

High Oil Pressure / Oil Pressure Relief Valve

6 posts in this topic

Hi all - I've just fitted a brand new crated engine (1.8 Black top Zetec R) and the oil pressure is 90PSI at tickover. General consensus seems to be that it's a problem the oil pressure relief valve - anyone know how to get to this as the pictures in my Haynes manual are for a Zetec-E and it doesn't look the same at all?

Cheers

Share this post


Link to post
Share on other sites
 

You should have some sort of warranty with a brand new engine, even reconditioned ones.

Share this post


Link to post
Share on other sites
You should have some sort of warranty with a brand new engine, even reconditioned ones.

Hmmm.. doubt it - it was from a main dealer but bought off eBay and they're miles away, don't think they'll be sending someone round to fix it insitu.

It should be a relatively easy fix if I had an idea where to locate it

Share this post


Link to post
Share on other sites

Kl. I would be phoning and asking them where it is then.

If a get a chance to look round one I'll let you know where it is.

Share this post


Link to post
Share on other sites
Kl. I would be phoning and asking them where it is then.

If a get a chance to look round one I'll let you know where it is.

Thanks - it never crossed my mind to call the dealer (must be their usual levels of helpfullness!), but I'll give them a go.

Share this post


Link to post
Share on other sites

Thanks - it never crossed my mind to call the dealer (must be their usual levels of helpfullness!), but I'll give them a go.

I had an Audi engine that did this. Trouble was when the valve opened it stuck open resulting in next to no oil pressure at idle.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0