Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


tonyw360

Rear Heated Window Not Working

3 posts in this topic

Hi all

Really need some advice if possible.

I have a 2001 focus 1.6 zetec and rear heated windscreen or mirrors not working. Ive checked fuse and relay you can hear switching, button lights and stays on but no 12v showing at terminals at back window...

Any ideas anyone ?

Thanks for any advice.

Share this post


Link to post
Share on other sites
 

Check the wiring in the conduit between the roof and the hatch.

A common problem is for the wiring to snap due to brittle/stiff insulation.

I'd recommend you get the whole loom checked as when one goes the others tend to follow closely.

Share this post


Link to post
Share on other sites

Ill have a check on it ! thanks for your advice..

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now