Jump to content


Show
Photo
- - - - -

Ford Fiesta Zetec Auto. Esp Problem

Ford Fiesta automatic ESP

  • Please log in to reply
3 replies to this topic

#1 Alex Clark

Alex Clark

    Newbie

  • Members via Twitter
  • Pip
  • 6 posts
  • Name: Alex
  • Ford Model: Fiesta Zetec Auto
  • Year: 2009
  • Location: Somerset

Posted 01 December 2012 - 07:11 PM

Hello everyvone, ...

Sorry if this question has been posted before, but cannot find.

Im owner of Ford Fiesta Zetec 1.4 automatic, ( late 2009 ) . I am new to cars.. so not very good with all instruments.

I am concered that my ESP light indicator does not show when put the ignition ON ?

However reading the instruction manual, it says if the indicator does not illuminate when the ignition is switched on or if it stays illuminated whilst driving, it indicates a
malfunction.

Can you advise if there is a valid reason for this? The car is under guarantee, I should claim for that ?

Also my partner has a Ford Mondeo Zetec 1.8 ( late 2004 ) and appear same of my, the light no show when the ignition is switched on,

It cant be coincidence both have fail the ESP. ?

There is not switch off of ESP available for that models.

Please can anyobe help?

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Stoney871

Stoney871

    Resident Peacekeeper

  • Super Mod
  • 14,406 posts
  • Name: Clive
  • Ford Model: Focus mk2 1.8 TDCI Sport
  • Year: 2007
  • Location: Devon
Contributor

Posted 01 December 2012 - 07:48 PM

Are you sure you have esp?
Search the web for 'etis ford' and enter your registration or vin which will give you the specifications your cars were built to.

#3 iNath

iNath

    ST-2 Mod

  • Super Mod
  • 3,591 posts
  • Name: Nathan
  • Ford Model: Molten Orange Fiesta ST-2
  • Year: 2013
  • Location: Buckinghamshire
Contributor

Posted 01 December 2012 - 08:52 PM

You don't have ESP, it only became standard on the Fiesta's in 2010.

#4 Alex Clark

Alex Clark

    Newbie

  • Members via Twitter
  • Pip
  • 6 posts
  • Name: Alex
  • Ford Model: Fiesta Zetec Auto
  • Year: 2009
  • Location: Somerset

Posted 02 December 2012 - 08:42 AM

Hi Stone, Hi Inah:

Thank you for your fast answer, has been checked as describe Stone, on FordEtis , and no appear ESP listed, then Stone comfirm that.
got big confusion, because the brochure say ESP come std on Zetec version, but maybe the bruchure is 2010. and not 2009 as told me.
Then problem sorted out.. thanks again
Alex


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users