Jump to content

- - - - -

Radio Problem

  • Please log in to reply
3 replies to this topic

#1 Tone2012



  • New Member
  • Pip
  • 1 posts
  • Ford Model: Mk5 black edition
  • Location: Essex

Posted 02 December 2012 - 01:33 PM

Hi all
I have a mk5 01 fiesta black, my radio has stopped working altogether now, used to work one day and not the next, now it's totally dead, all other electrics seem fine, clock and int light work, so fuse must be ok, I put another radio in and that was dead as well, but it works in another car,it's been driving mad not having any music on way to work.

What else can it be and where should I look



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 RightcarBev



  • New Member
  • Pip
  • 6 posts
  • Name: Bev
  • Ford Model: Focus ST. (Fiesta ST Next yr)
  • Location: Yorkshire

Posted 02 December 2012 - 02:45 PM

Just because the clock and int light work does not 100% rule out it being a fuse. I would check the fuses to be sure.

#3 Stoney871


    Resident Peacekeeper

  • Super Mod
  • 19,644 posts
  • Name: Clive
  • Ford Model: 2015 Focus ST3 250BHP
  • Year: 2015
  • Location: Devon

Posted 02 December 2012 - 03:21 PM

Seperate fuse altogether.

#4 eyemdee


    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 157 posts
  • Name: Ian
  • Ford Model: Fiesta 1.4 Titanium Automatic GONE!
  • Year: 2011
  • Location: Nottinghamshire

Posted 02 December 2012 - 04:01 PM

Definitely a power issue if another good radio was dead as well. Almost certainly a fuse in the radio supply line.

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users