Jump to content


Show
Photo

Loss of Dashboard/Traction Control Light Permanently On


  • Please log in to reply
2 replies to this topic

#1 kazzy7004

kazzy7004

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: 2.0L Ghia
  • Location:

Posted 02 March 2009 - 11:37 AM

Hi,
I have a focus 2.0L Ghia 03 plate. Just lately the traction control light comes on by itself and then I lose all the dashboard display - the trip meter and milometer LED display goes to ------, the spedo, rev, fuel and oil needles all drop to 0. I've just rang the local Ford garage and been told to take it in so they can diagnose the problem for 94!! Which to be honest I can't really afford.... I can't seem to find anything about this so was wondering if anyone here could help? I have just had an MOT and 4 new tyres - perhaps something was 'knocked' during this???
Any advice gratefully received.
Thank you!!

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 SierraYankee99

SierraYankee99

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 859 posts
  • Ford Model: Ford
  • Location:

Posted 02 March 2009 - 12:13 PM

Sounds like a faulty cluster to me

#3 SHANES9818

SHANES9818

    Member

  • New Member
  • PipPip
  • 15 posts
  • Ford Model: Focus

Posted 04 March 2009 - 02:03 PM

Hi there

i also have the same problem with my ford focus v reg.

the dash board is alright but the traction light appears to be on all the time, what do you think that might be?

can any one help???


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users