Jump to content


Photo
- - - - -

Speedo Droping To Zero


  • Please log in to reply
17 replies to this topic

#16 Stoney871

Stoney871

    Resident Peacekeeper

  • Super Mod
  • 15,829 posts
  • Name: Clive
  • Ford Model: Focus mk2 1.8 TDCI Sport
  • Year: 2007
  • Location: Devon
Contributor

Posted 30 January 2013 - 01:47 AM

You're welcome any time Nigel.
I know that the VSS is a royal pain to sort out, so anything i can do to assist is my pleasure.
Put it this way, if you go to a Dealer they will insist that you need a diagnostic (at least £75) just to tell you what you already know, charge you probably 2 hours labour, their price for the part (which always seems higher than you can get it yourself, but god forbid you ask them to fit a self sourced part) and then tell you some codswallop about this part or that part also needs doing.
For £20-£25 and a few knuckle scuffs and copious swearing i know which i'd rather do.

Final pointer though, do not for the love of all things holy snap the sensor off when removing it, that is a whole other level of hell.
As you said, copious amounts of penetrating fluid, and a firm but steady hand will see the job through to completion.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#17 nigel129

nigel129

    Member

  • New Member
  • PipPip
  • 16 posts
  • Ford Model: 52 Fiesta Lx 1.3 petro

Posted 30 January 2013 - 08:55 AM

Hmmmm not as easy to WD40 as i thought it might be, seems to be some sort of silver tape 2 inches above the top of the sensor, can a remove this tape ??
nigel

#18 Navarro93

Navarro93

    Member

  • Budding Enthusiast
  • PipPip
  • 18 posts
  • Ford Model: Fiesta Black
  • Location: Hampshire

Posted 08 August 2013 - 12:57 PM

yes, you can. the silver tape is just head shield tape. On another note, I've managed to get my pin out (after snapping the clip off lol) and even with the pin right out I still can't get the bl00dy sensor out. I've tried wiggling, twisting, levering and tapping, but it just won't bl00dy budge.

any hints or tips from experts?




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users