• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


screamer

Indicator Not Cancelling, What Else Can Be The Problem?

5 posts in this topic

My partners 2002 fiesta left turn indicator does not cancel, i've got another indicator stalk from ebay, replaced it, but it's the same

what else can look at replacing to try and fix this?

Share this post


Link to post
Share on other sites
 

Does it only happen in one direction or both?

Probably something in the clock spring mechanism that isn't turning it off I imagine

Share this post


Link to post
Share on other sites

I have the same problem with the left signal not canceling. The right one does, but never the left. There's a difference in feel between left and right too, as if one direction needs moving mor than the other before it clicks, if that makes sense. Also, the flash seems a bit weird, as when you pull it all the way, it flickers, as if it's a loose connection. I wonder if our problems are similar in source.

Share this post


Link to post
Share on other sites

This happens on both of my indicators. Its not a problem cancelling them manually, but would be greatful to find a reason why :)

Share this post


Link to post
Share on other sites

Does it only happen in one direction or both?

Probably something in the clock spring mechanism that isn't turning it off I imagine

only the one direction, left, i took out the stem, part number XS6T11K665CA, the wee white plastic bit that locates into the steering wheel, seems to have a bit of resistance when you put the indicator on one way, but not very much the other, it's the same on both stalks i have, coincidence??

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now