• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save


andrewl6527

54Plate Tdci Focus

4 posts in this topic

I've got a 54 focus diesel had trouble starting so I changed the glow plugs.solved... Now and then the glow plug light flashes and I lose all power and the car cuts out. Switch off and alls ok for a few days then it happens again.

Been told its a sensor and also the turbo is on its way out.

Anyone had the same problem and resolved this or anyone know what is needed

Many thanks

Share this post


Link to post
Share on other sites
 

So you saying its defiantly the turbo

Share this post


Link to post
Share on other sites

I too had this problem with my car, focus tdci 115. It would just cut out at 70mph. It turned out to be my injectors.

It cost a lot of money but it fixed the problem

A nearby diesel delphi speclised fixed my car but since then i have found cheaper delphi garage.

They could check for any faults on their computer,

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now