Jump to content


Photo

Rear Window De Mister Not Working


  • Please log in to reply
9 replies to this topic

#1 phatdan

phatdan

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Ford Model: 2000 fiesta zetec se
  • Location: Essex

Posted 16 December 2012 - 03:50 PM

Hi guys, im new to here so please be gentle lol

i have a 2000 fiesta zetec se which i love dearly but as winter has come i have just realised that my rear window de mister does not work, i have checked all the fuses, the light on the switch turns on when it is pushed and i have checked if there are any breaks in the lines of the window which there are not.


Any help would be greatfully accepted.


thanks

Have something to contribute?

Sign in or register to start a topic...

#2 Preee

Preee

    Ford Fruitcake

  • Moderator
  • 4,061 posts
  • Name: Paul
  • Ford Model: Focus Tit X Mk3 | Fiesta Zetec Mk7
  • Year: 2012
  • Location: Shropshire
Contributor

Posted 16 December 2012 - 03:59 PM

You need to get a meter across the terminals and check you have power , are they wired direct to the screen via the hatch or are they those spring terminals that connect when the boot is closed?

#3 phatdan

phatdan

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Ford Model: 2000 fiesta zetec se
  • Location: Essex

Posted 16 December 2012 - 04:03 PM

hi paul, erm the boot has two conections , one either side that are kinda welded to the screen but i also have the 4 pronged spring terminal when the boot closes although only 3 of them are standing proud, not sure if that makes any difference?

#4 Stoney871

Stoney871

    Resident Lawman

  • Super Mod
  • 12,920 posts
  • Name: Clive
  • Ford Model: Focus mk2 1.8 TDCI Sport
  • Year: 2007
  • Location: Devon
Contributor

Posted 16 December 2012 - 04:04 PM

Afaik all four need to make contact.

#5 phatdan

phatdan

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Ford Model: 2000 fiesta zetec se
  • Location: Essex

Posted 16 December 2012 - 04:06 PM

ah well like i said only 3 on the boot door are sticking out, is there a fix or do i buy a new one?

#6 Preee

Preee

    Ford Fruitcake

  • Moderator
  • 4,061 posts
  • Name: Paul
  • Ford Model: Focus Tit X Mk3 | Fiesta Zetec Mk7
  • Year: 2012
  • Location: Shropshire
Contributor

Posted 16 December 2012 - 04:08 PM

it could just be stuck down with dirt , try wd40 and see it you can get it back up , if not then the spring may have broken , then i'd go and get one from scrapyard or ebay , but thats more than lightly your problem

#7 phatdan

phatdan

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Ford Model: 2000 fiesta zetec se
  • Location: Essex

Posted 16 December 2012 - 04:21 PM

thanks paul, just put some wd40 on and managed to get it out but ny the looks of it the spring has gone.

What would be the correct wording to search for it on ebay?

Thanks by the way

#8 Stoney871

Stoney871

    Resident Lawman

  • Super Mod
  • 12,920 posts
  • Name: Clive
  • Ford Model: Focus mk2 1.8 TDCI Sport
  • Year: 2007
  • Location: Devon
Contributor

Posted 16 December 2012 - 04:27 PM

Try ford fiesta contact.

#9 Preee

Preee

    Ford Fruitcake

  • Moderator
  • 4,061 posts
  • Name: Paul
  • Ford Model: Focus Tit X Mk3 | Fiesta Zetec Mk7
  • Year: 2012
  • Location: Shropshire
Contributor

Posted 16 December 2012 - 04:32 PM

when doing a search for ford fiesta 4 way boot pins all i can see is three way

http://www.ebay.co.u...t pins&_sacat=0

#10 phatdan

phatdan

    Newbie

  • New Member
  • Pip
  • 6 posts
  • Ford Model: 2000 fiesta zetec se
  • Location: Essex

Posted 16 December 2012 - 04:56 PM

yes , ive just seen the same one paul, although it states that its for models up untill august 2000, mine was made after. they seem hard to find.

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users