Jump to content

  •  

Show
Photo

Focus C-Max Electrics ?


  • Please log in to reply
1 reply to this topic

#1 delboy

delboy

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 406 posts
  • Name: martin
  • Ford Model: c-max ghia 1.8 petrol
  • Year: 2004
  • Location: Somerset

Posted 20 December 2012 - 06:07 PM

my 54 plate c-max is doing the following

a bugger to start but not all the time
the red warning light came on the other day whilst driving so i stopped turned off then restarted & all was fine
and i just noticed the time clock on the radio is not about 8 hour wrong.

any ideas on what this can be please guys.
btw
had new alternator fitted about 2 yrs ago.

if i got to replace the battery do i need to remove anything like bulk head to get the thing out ifso
is there any picks on how to do it please

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Preee

Preee

    Ford Fruitcake

  • Moderator
  • 4,099 posts
  • Name: Paul
  • Ford Model: Focus Tit X Mk3 | Fiesta Zetec Mk7
  • Year: 2012
  • Location: Shropshire
Contributor

Posted 20 December 2012 - 06:58 PM

my 54 plate c-max is doing the following

a bugger to start but not all the time
the red warning light came on the other day whilst driving so i stopped turned off then restarted & all was fine
and i just noticed the time clock on the radio is not about 8 hour wrong.

any ideas on what this can be please guys.
btw
had new alternator fitted about 2 yrs ago.

if i got to replace the battery do i need to remove anything like bulk head to get the thing out ifso
is there any picks on how to do it please


If it is the battery then it will just be a Battery cover to remove , and the clamp , best to get it checked out


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users