Jump to content


Photo

Help Please My Car Keeps Stopping!


  • Please log in to reply
1 reply to this topic

#1 lunylisa

lunylisa

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: focus zetec
  • Location: Kent

Posted 24 December 2012 - 09:44 PM

hi i have a ford focus zetec x reg for the last 5 weeks the focus has just been stopping whilst driving first the speedo drops and occassionaly the battery will flash then the car engine will just stop running it has happened whilst doing 70 mph on a motorway and on town roads doing up to 30 i have had the battery and alternator looked at but both seem fine ?what could be the problem as it only happens once or twice a week ?
any advice would be apprieciated thanks
oh and merry christmas everyone

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Stoney871

Stoney871

    Resident Peacekeeper

  • Super Mod
  • 15,548 posts
  • Name: Clive
  • Ford Model: Focus mk2 1.8 TDCI Sport
  • Year: 2007
  • Location: Devon
Contributor

Posted 25 December 2012 - 06:07 AM

Check the wiring to your Speedo sensor, it sits on top of the back of your gearbox.
The sensor is a known problem on the Mk1 focus and is cheap to get a replacement but the removal of the old one can be a sod as it is a tight fit and the retaining pin snaps easily.
If you source your own part i.e. from eBay, make sure you get a pin too.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users