Jump to content


Show
Photo
- - - - -

Mk6 1.4 Zetec Running Rich


  • Please log in to reply
1 reply to this topic

#1 sean.round

sean.round

    Newbie

  • New Member
  • Pip
  • 8 posts
  • Name: Sean
  • Ford Model: MK 6 Fiesta Zetec
  • Year: 2003
  • Location: Warwickshire

Posted 29 December 2012 - 09:25 PM

Hi Guys,

My 1.4 Fiesta Zetec is running really rich at the moment. I am lucky if I crack 31mpg round town, yet, get 40-41mpg on the motorway... I occasionally get the Engine Managment Light come on, which if you clear with a DTC reader, wont come back on for months on end. Error code seems to signify Lambda Sensor, but I was wondering if anyone else had any other suggestions before I fork out for them?

Sean

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 DanGersFord

DanGersFord

    Dan The Gas Man

  • FOC Supporters
  • 3,498 posts
  • Name: Daniel
  • Ford Model: Fiesta ST3
  • Year: 2014
  • Location: Scotland
Contributor

Posted 29 December 2012 - 11:46 PM

Sounds like lambda sensor not giving correct air/fuel mixture hence why you're going through so much fuel. My brother had a similar problem and after changing the lambda sensor 3 times the garage he was taking it to noticed he had a big hole in his back box. After that was replaced it was fine


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users