Ford Owners Club - Ford Forums Messages

FORD FAIR – SILVERSTONE – 6TH AUGUST 2017

Join us on the Ford Owners Club stand at Ford Fair, Silverstone on Sunday 6th August 2017.

Click this link to find out more

    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear


chris 1

Fiesta 'y' Plate Turbo D Losing Power

1 post in this topic

Hi

My little fiesta has had a strange intermittent problem over the last week or so.

It has dropped in power then picked straight back up a couple of times on acceleration, but tonight it went into a sort of limp mode and would not accelerate beyond about 30 mph. I pulled over and switched it off and back on again, and all seems fine again.

Even in the fault condition the engine runs and ticks over fine, but just revs low as if it had a limiter on it.

Has anyone ever had this sort of fault?

Do these cars use computers that may need reset?

Hope someone can help.

All the very best,

Chris.

Share this post


Link to post
Share on other sites
 

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now