• Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Share Your Car Experience
      Share Your Car Experience
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


russellf

Ford Sync Track Order From Usb

33 posts in this topic

Hi, I have a B-Max with Sync. It works really well, apart from one small problem. When playing albums from the USB stick the system plays the tracks in alphabetical order, rather than the proper track order. Of course how 'important' this is depends on the album !! However, I would like it to play them how they were originally produced. Does anyone know if this is possible?

Anomaly likes this

Share this post


Link to post
Share on other sites
 

There is one way that would definitely work, and that is to name all the tracks with their track number first. For example, track number one on the CD would be named "01 ..." and so on. Could be very time consuming if you have a lot of tracks, but its guaranteed to work.

Share this post


Link to post
Share on other sites

I desperately suffer from this problem! the link above doesn't work. no way to update sync either.

if anyone has found a solution, please share it!!

Share this post


Link to post
Share on other sites

Anyone want a free head unit and sync module?

Dammed thing is awful :(

As Russel said, sync plays all our music alphabetically. I've emailed Ford again about this and will post there response here for you guys.

Anomaly likes this

Share this post


Link to post
Share on other sites

Anyone want a free head unit and sync module?

Dammed thing is awful :(

As Russel said, sync plays all our music alphabetically. I've emailed Ford again about this and will post there response here for you guys.

Hello Willy and thank you for your responce. Yes indeed Sync plays tracks alphabetically, but it's not really Ford's fault since Sync is developed and supported by Microsoft.

What's also the question is why then there's a sorting option (*/A-H) which does sort tracs but sync still plays them alphabetically... can't tell you how frustrating it was to me :cry:

post-56197-0-80293300-1405109270_thumb.j

Share this post


Link to post
Share on other sites

So you have tried numbering tracks in order?

I had this problem with my (self fitted) Ford USB MP3 interface and using my PC I made sure that the file names were numbered in order and also that the correct track order was also added, works fine now.

Worth trying before chucking your system.

Single click on the file and then edit the track number at the bottom of the window.

Right click the file to rename the track with the number prefix.

(sorry if eggs are being sucked here)

post-28494-0-25360500-1405111886_thumb.j

post-28494-0-59443100-1405111894_thumb.j

Share this post


Link to post
Share on other sites

So you have tried numbering tracks in order?

lol, i've even tried ordering them with abc instead of 123!! but come on...

all my collection is ordered like this (see screenshot), i don't imagine how else one can keep a collection.

Single click on the file and then edit the track number at the bottom of the window.Right click the file to rename the track with the number prefix. 

thank you for trying to help, but it's not it.

it's a known SYNC problem which i believe can be solved with SYNC Firmware update, but there seems to be no way to update it if you're outside the US :unsure:

post-56197-0-12291600-1405113037_thumb.j

Share this post


Link to post
Share on other sites

Yeah stoney I did eventually do that and it does work but as you can guess if you select play all it then played all the track 1s. All I want sync to do is play my music in folder and track order aaahh.

Anomaly likes this

Share this post


Link to post
Share on other sites

Numbered the folders as well?

Sent from my S5

Share this post


Link to post
Share on other sites

Numbered the folders as well?

Sent from my S5

Erme no I never thought of that.

Just need to update a few hundred folders now ;)

Share this post


Link to post
Share on other sites

Labour of love.

Only needs doing once ;)

Sent from my S5

Share this post


Link to post
Share on other sites

my SYNC doesn't play "folder after folder" at all - it only plays one folder and then repeats playback from the first track; same with playlists.

but this is not the problem. the problem is that there is no possibility to play tracks in their numerical order.

Share this post


Link to post
Share on other sites

I just stumbled upon this problem myself so thought I would add some solutions for anyone else who's bugged by this.

There are two solutions - simple and slightly more complex.

Simple:

Go into Windows, open up your USB to see the tracks within a folder. View the files as "view/details" rather than icons, to bring up a list of files with columns of meta-tag info to the right (track number etc). If you can't see "title" as a column, right click on the headings towards the top of the window, tick "title" in the options list, so you can see the titles in a column to the right of the filename. Your task it to now delete all the title-tags. By doing this, the SYNC in your Fiesta will look to the file name next instead, which is more likely to include track numbers at the beginning. You can delete the titles in bulk by selecting them all, right clicking, going to properties, then deleting the "title" box.

Complex (actually more simple once you get into it):

Download "MP3TAG". Its free and simple to download/install/use.

Open a directory - choose your MP3 folder.

Highlight all the files, then choose "Filename to Tag" as an option from the little boxes above.

It will ask you for what tag to use - choose "title". It will then paste all the filenames (which usually include track numbers) into the Title field.

Voila!

Hope that helps.

smneal, Stoney871 and Anomaly like this

Share this post


Link to post
Share on other sites

I have the same problem today and found this video which worked for me.

It was reasonably straight forward, and I now have 32G of music on a £5 usb memory with playlists for all situations - works like a dream and you don't have to rename all the files.

Note - I couldn't get it to work with media player - but winamp worked a treat.

BTW - does anyone else find it annoying that you can't use voice commands to select the Radio anymore- my old 2011 model had it but the 2014 dosen't.

Anomaly and Stoney871 like this

Share this post


Link to post
Share on other sites

@WillBox Good answer. Sorted mine now. Used the MP3TAG option. Only thing is now the number is part of the title, but I can live with that! Cheers

Stoney871 likes this

Share this post


Link to post
Share on other sites

Been playing with MP3Tag tonight and can 100% confirm that as long as you have a track number in the file name and remove the title data for all files then they will play in order just fine.

I like too that the program lets you add the correct album art far more accurately and easily than with the likes of Windows Media Player etc.

It's also handy for stripping out all the extra crap data that Amazon add to any purchased MP3 files.

 

Share this post


Link to post
Share on other sites

Hey, I have a Focus and I have been struggling with the same problem. I use mostly the USB storage to my music, and then one day I realized one artist plays in order, then I thought instantly that it has to be something about ID tags, I haven't found a solution but I will post the properties displayed for the artist that is correctly played [left] and other that doesn't [right].

I hope it will help someone to find a solution, I just have found this and need to investigate more about the different type of ID tags. Something by intuition tells me that if SYNC is a system developed by Microsoft, it could be some embededd unix like system, by means of unicode standarization, and that the APE tag is making the difference in order interpretation because it supports UTF-8 character codification.

Codification of characters is a pain in the !Removed! if you have tried Linux based OS's and browsed a few webs with a different Unicode standard... 
 

Ford Sync.PNG

Share this post


Link to post
Share on other sites

Try mp3tag.

Delete the track names but ensure you number the filenames in the order they need to play in and also populate the track number column.

For compilation/various artist albums change the artist names to the album name.

Sent from my SM-G930F

Share this post


Link to post
Share on other sites

Glad to help 😎

Sent from my SM-G930F

Share this post


Link to post
Share on other sites

I have had this alphabetical album playing problem intermittently: very annoying. Try turning off Gracenote in options, and then reindexing. It just worked for me, suspect the problem is here. Can turn back on afterwards if you like.

Stoney871 likes this

Share this post


Link to post
Share on other sites

Aye, Gracenote is a pest.

It remains solidly off in my car.

It even ruins the album art being displayed as well.

Sent from my SM-G930F

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now