Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


loomis9301

Mk1 Focus Speedo Issue

2 posts in this topic

Firstly, Hi all.

To be perfectly honest I only joined as I have a speedo issue on my 2000 MK1 Focus that I'm seeking a little advice on, but turns out I'm already pretty hooked on this site! Blessing in disguise and all that...

Yesterday, whilst doing about 55-60mph, the speedo suddenly dropped to 0 for about 5-10 seconds and then jumped back up to the speed I was doing again. I didn't lose any power or performance at all and nothing else failed, all the other dials, fuel, temp, revs etc stayed perfectly fine. Anyone know what this could be?

Thanks.

Share this post


Link to post
Share on other sites
 

Hi, what you have there is the Speedo sensor failure which is quite a common problem.

I have recently posted a message and YouTube video concerning that problem.

Have a quick look through the posts for the last 24 hours and you should find it.

You can get the sensor and pin through eBay for about £20 or so.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now