Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


chiefwiggumpi

Help....newbie With 2 Issues....one Radio And One Mirror Related

2 posts in this topic

Hi guys

New to here so bear with me...

I have two issues that im hoping this forum can help me with as ive read lots of useful stuff on here. Own a 2008 1.25 previous model Zetec Climate.

1. This week the radio (Ford 6000CD) has had a problem. The display very intermitently but now more frequent shows "Phone". The car has been owned by us since new and has no phone connection. The radio loses all use of it buttons when it switches to "phone" except the volume and bass/treble button. Eventually the radio might start working. Ive contacted local dealers who all state theyve never heard of the problem.

Ive researched tne internet and even found a youtube video of someone else's car with the same problem if it helps. From what ive read im assuming the radio is short circuiting somewhere inside the unit? Ive been quoted £415 plus vat plus fitting from dealers for a replacement which we cant afford. Does anyone know is it fixable or should i start to look on ebay and the like for a replacement? Anyone else had this problem and how do you fix it? Or not?!

2. Second issue which has been dogging the car for ages...the electric adjustable mirrors work fine, the problem lies in that the heating element to BOTH mirrors dont work. Its been like this for a while and everytime i took it to the dealers they keep saying there is power the mirrors (i know that myself as they turn the glass!) but they cant see any issues with the heaters....and make sure i use the rear heater to activate them. I know all that and today sat for 5 minutes with condensation on the mirrors. Never budged it not one bit....tried the fuse its fine. Any other ideas of anyone else had this with BOTH mirrors? How did you fix it?

Any help would be appreciated!

Thanks

Share this post


Link to post
Share on other sites
 

Can't help with the radio but the heated mirrows will take ages to evaporate condensation. Wait untill there frosty to test.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now