Ford Owners Club - Ford Forums Messages

FORD FAIR – SILVERSTONE – 6TH AUGUST 2017

Join us on the Ford Owners Club stand at Ford Fair, Silverstone on Sunday 6th August 2017.

Click this link to find out more

    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save


MrG

Passenger Side Engine Mount Question

2 posts in this topic

Morning chaps - I still have a vibration/tremor at idle in my Focus Mk1 1.6 05 plate petrol beast; so far I've replaced PCV hose which was all squishy & PCV valve, VSS (as speedo kept dropping to zero) & the plugs & coil pack look ok.

Googling around, the passenger side engine mount seems to crop up as being a problem - firstly, is this the right part - http://www.fordparts...33019_c_597.htm

EDIT - just been thinking that the sites I was reading info about the passnger mount on were American - so I assume that their passenger side, would be our drivers side - so the hydraulic mount, not the one I've linked too above?

Secondly, is there any way of 'testing' the existing one?

Many thanks :)

Share this post


Link to post
Share on other sites
 

Engine mount is filled with oil poo the airbox out and youll see it if its gone the engine will rock and there will be oil keaking from the mount ive found this is rarely the issue

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now