• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


mrc81

Hello And Happy New Year!

6 posts in this topic

My name is Matt and I drive a Focus 1.6 Ghia and an Escort 1.8i LX.

Joined here to be more involved with my cars and to get to know others with similar interests - Fords!

Cheers

Matt

Share this post


Link to post
Share on other sites
 

Hi welcome :)

Share this post


Link to post
Share on other sites

Hi dezwez,

Cheers for the responce.

I see you are a fellow Focus driver.

I've had mine now for 7 years, it's an 03 plate, and i've only had one problem. The speedo sender unit/sensor failed as do quite a lot of '03/53' focus' did.

Any problems with yours?

Matt

Share this post


Link to post
Share on other sites

its had speed sensor a new clutch but run great since ive had it 138000

miles and the engine looks brand new not bad for a petrol i love it

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now