Jump to content


ABS problem

  • Please log in to reply
2 replies to this topic

#1 Marko



  • New Member
  • Pip
  • 5 posts
  • Ford Model: Ford Mondeo 1.8 TDCi Titanium X
  • Location:

Posted 07 March 2009 - 10:18 AM

Hi. Please bear with me as I'm new to this forum stuff!

My wife has a Ford Ka, about 5 years old. Very low mileage and only used for short trips. Recently the ABS warning lights have come on, and the garage we have used are suggesting a new ABS control unit is required ... at a cost of over 500!!

Has anyone suffered the same problem, and can you offer any advice?

Many thanks

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 delboy


    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 593 posts
  • Name: martin
  • Ford Model: c-max ghia 1.8 petrol /ka 1.2 mk2
  • Year: 2004
  • Location: Somerset

Posted 07 March 2009 - 03:35 PM


have you had the brakes looked at recently ?

if you have then it's down to bleeding them properly

i would take for fords to get them to look at it as they have the abs diagnostics to do the job

there may be trapped air in the system

they use a ford fds 2000 diagnostic test equipment.
they can do the job peoperly m8
best to be on the safe side

#3 SierraYankee99


    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 859 posts
  • Ford Model: Ford
  • Location:

Posted 07 March 2009 - 07:32 PM

It will probably be a faulty wheel speed sensor. Not only does this control traction control but also ABS.

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users