Jump to content


Show
Photo

Coil Pack Problem,


  • Please log in to reply
1 reply to this topic

#1 gottschlich26

gottschlich26

    Newbie

  • Members via FB
  • Pip
  • 2 posts
  • Name: Gavin
  • Ford Model: 2007 Focus Zetec
  • Year: 2007
  • Location: Dumfriesshire

Posted 14 January 2013 - 08:08 PM

Hi,

First post on the forum.

I have a 2007 focus zetec with 74500 miles. I have had it for 18 months and in the last 6 months I have had 3 coil packs fitted. When the management light comes on the garage say it is the coil pack and they replace it. But there must be another issue causing the issue.

Can anyone shed any lights on the matter.

Thanks in advance

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 artscot79

artscot79

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 6,977 posts
  • Name: arthur
  • Ford Model: focus mk2 ti-vct
  • Year: 2006
  • Location: Fife

Posted 15 January 2013 - 03:09 AM

Water leakingvinto the spark plug ports is a common fault this will easily knacker a coil pack the garage may be using cheap coil packs these wont last at all should be a bosch coil pack going in and the leads may need replaced causing the coil pack to go faulty when doing this job you should change the spark plugs and leads and the coil pack


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users