• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save


Hewby45

Fiesta S Mk7 Lumpy Engine [Year 2009+]

13 posts in this topic

I'm being told that this is normal for my car (by Ford), though I don't believe this is correct, has anyone else had issues or should I believe what I am being told? Thanks

Share this post


Link to post
Share on other sites
 

Moved to Fiesta Forum.

I assume you have a Zetec S? Which engine are you referring to? Also what do you mean by lumpy?

Share this post


Link to post
Share on other sites

If its a zetec s its a 1.6 either vct or tdci

Share this post


Link to post
Share on other sites

It is a zetec s, sorry! It's a 1.6 ti-vct. It's lumpy when the revs pick up between 1500-3000rpm, when the car is in neutral. You feather the throttle between 1500-3000rpm and its noticeably lumpy. Thanks

Share this post


Link to post
Share on other sites

What do you mean by lumpy

Share this post


Link to post
Share on other sites

By lumpy I mean a bit of a murmur, not smooth like all my other fords have been

Share this post


Link to post
Share on other sites

Hi

How many miles has the car covered.

When was it last serviced,

Does The car show these symptoms when cold or hot or both.

Jamie

Share this post


Link to post
Share on other sites

it's done just over 37000 miles, serviced literally a week ago and does it when it is hot and cold, thanks

Share this post


Link to post
Share on other sites

it's done just over 37000 miles, serviced literally a week ago and does it when it is hot and cold, thanks

Has it always done it, or only since the service?

Share this post


Link to post
Share on other sites

I don't know as I have only just bought it. I just need to know if it is usual for this car to be like that or not, Ford are saying it is.

Share this post


Link to post
Share on other sites

I'd expect a diesel to be lumpyish but not a petrol... Can u get a second opinion from another ford garage?

Share this post


Link to post
Share on other sites

Hi

I would say it isn't normal. My zs has done 43000 and isn't lumpy at all.

If its got warranty take it to ford.

Regards

Adrian.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now