Jump to content


Photo

Water Damage To Bsi Ecu

BSI ECU

  • Please log in to reply
No replies to this topic

#1 Bazzab

Bazzab

    Newbie

  • New Member
  • Pip
  • 3 posts
  • Ford Model: Focus 1.6 Zetec 2009
  • Location: Lanarkshire

Posted 16 January 2013 - 07:52 PM

Hi all,

I posted this in an update to my previous thread regarding my wipers which stopped working, but I thought I have more luck starting a new thread for this particular query.

I have sourced the problem of the wipers not working - its the BSI ECU which has became water damaged.

I have found a salvaged ECU which is nearly the same Part Number. The question is, will it be suitable?

My part number is 7M5T - 14A073 - CE, the part I am being offered is 7M5T - 14A073 - CC.

Will this be OK, can it be re-programmed. My auto electrician has the software to fault find and reprogramme, or do I need to take this to a Ford garage for fitting and programming?

Any help is very much appreciated. I havent had my car for 3 weeks making travel to work a bit tricky and demanding!

Also, is the cause of this damage likely to be the pollen filter or the filter housing itself?

Thanks in advance

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users