• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members


stevehk

Mk6 1.6 Tdci Cold Rough Idle

10 posts in this topic

Hi Chaps,

Apologies if this is placed somewhere else, but I have just bought an 06 1.6 TDCi Zetec S fiesta.

When started in the morning it seems to have a rough idle with some minor smoke on start-up, drives fine and within 20-30 secs it idles fine, no problems when its warm.

I checked the menu on the dash display, it doesn't appear to have any fault codes on there, but one thing I have noticed, I have never seen the glow plug light illuminate during starting.

Next step for me is to run some injector cleaner through the system, but has anyone had similar problems ?

Thanks,

Steve

GJP 64 likes this

Share this post


Link to post
Share on other sites
 

Could be the fuse blown on the glowplug circuit or the glowplug relay. How many miles has the car done?

Share this post


Link to post
Share on other sites

Hi Mate,

Its roughly 51,000, I did a lamp check to try and find where on the dash the glow plug indicator sits, the lamp does show on the test. But of course that could just be the lamp circuit.

Share this post


Link to post
Share on other sites

Put the lamp across the glowplugs see if they get power when you turn the ignition on. If they do the glowplugs may have blown.

Share this post


Link to post
Share on other sites

Hi sorry, I meant lamps on the dashboard, I haven't been under the bonnet yet.

Off hand do you know where the glowplug fuse and relay is within the car, i'll check that first.

Share this post


Link to post
Share on other sites

Should be in the box under the bonnet on the right hand side if I remember correctly.

Share this post


Link to post
Share on other sites

Great thanks very much for your help, out of interest do you have any idea when the glow plugs should normally come on ?

Share this post


Link to post
Share on other sites

On my current 2011 Fiesta and my old 2003 Mondeo & 2005 Fiesta the dashboard light always came on, the ECU should check the engine temperature and power the glowplugs up accordingly. So if the engines hot no need to power them.

Don't know what the threshold temperature is maybe someone on the forum knows.

Share this post


Link to post
Share on other sites

Heya,

Just had a very helpful call from Vospers (Ford Dealer down my way), they asked the kind of runs i'm doing in the car, i'm doing fairly short 10mins runs to work, (no idea what the previous journeys were like). The chap then immeadiately pointed me to the EGR valve and suspected its was clogged, which would explain the rough idle (it was hunting above the normal idle point, rather than under) and the smoke puff on start-up.

He recommended to run it 2.5k rpm for 10mins, get the system hot to clear it, once a week, so I will go for that at the weekend. He also pointed me to diesel grades, again no idea what the previous owner used, but its now running on V-Power diesel.

I also asked about glow plugs, he said they would be unlikely to come on unless it reaches -2, even then they may not be needed.

Thanks for your help.

Will post outcome.

Steve

Share this post


Link to post
Share on other sites

Having owned a variety of Ford diesels that won't clear a blocked EGR valve, the only way to clear it is to remove and clean the muck off by hand, a very dirty job.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now