• Share Your Car Experience
      Share Your Car Experience
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale


kevctr

Mondeo Fault Code Help

17 posts in this topic

hi all im new to the forum and in need off some help iv searched the net and im getting confused with all the answers as they seem to say opasit things

i have just brought a 03 mondeo 2.0 130

when u drive the car u get the glow light flashing then car cuts out totaly if u turn it off and on again it will restart and keep going till the next time and so on iv had it checked and results were

fault codes are

p0251 injector pump meter control ?

p1000 test incomplete ?

u1039 vehicle speed signal missing or incomplete ?

p1211 injector control pressure sensor above/below desired ?

i had a diesel leak from the piep that goes up the back off the manifold from injector pump up to the injector rail so iv orderd a new pipe and will be fitting tomorow

im in need off some help trying to understand the cause or understanding the fault codes

i know these cars have a problem with injectors and in an ideal world i would say just replace everything but i cant afford to do this

so im trying to understand the codes so i can try and narrow down the problem

any help would be great many thanks kev

Share this post


Link to post
Share on other sites
 

first off fix the leak as this is the most likely cause of the pressure related codes the p1211 means the rail pressure is incorrect and p0251 the pump is not supplying the correct amonut of fuel. this can be the pump cant keep up because of the leak. once the leak is sorted clear codes and recheck. if codes persist try a fuel filter and leak off test. forget about the p1000 its nothing but seperate the others into 2 areas pressure related and electrical related then focus on each in a methodical manner.

i had the same pressure related codes on my tdci 115bhp 54 plate mondeo turns out i have 3 injectors leaking back way to much.

leak off test showed injector 1 3ml, 2 35ml, 3 50ml and 4 50ml and this was in a 25-30 second period test conducted by garage so not 100% on timings

Share this post


Link to post
Share on other sites

thanks for your help what could give me the u1039 code

Share this post


Link to post
Share on other sites

could be anything from muck on the sensor, to a faulty sensor, or just a combination of the other error codes, they can sometimes cause red herrings.

Share this post


Link to post
Share on other sites

dont mean to sound thick but what sensor the cam posision sensor ?

Share this post


Link to post
Share on other sites

I got the first and last codes on my old focus every time I had my tuning box on it.

Maybe the old owner had one?

Long shot but worth mentioning...

Share this post


Link to post
Share on other sites

I got the first and last codes on my old focus every time I had my tuning box on it.

Maybe the old owner had one?

Long shot but worth mentioning...

thanks but he was 70 so long shot lol

Share this post


Link to post
Share on other sites

the code relates to missing data in the canbus system, as your car is pre obd2 what reader are you using to get the codes as it might not match up correctley and throw this up.

Share this post


Link to post
Share on other sites

im unsure i had some one check it for me i didnt do it myself

Share this post


Link to post
Share on other sites

right changed the pipe and stoped the leak car runs ok with no fault coming up but is a bit rought in 5 and 6 at low revs could this just clear its self after time

Share this post


Link to post
Share on other sites

How do u mean rough?

Share this post


Link to post
Share on other sites

like your in the wrong gear bit juddery if you put your foot down it splutters then goes fine

Share this post


Link to post
Share on other sites

Only 5th and 6th,

Wonder if its the DMF getting a bit rattly, this would be exaggerated in the higher gears at lower revs

Share this post


Link to post
Share on other sites

yer iv just been out again and it seems to be a bit better

Share this post


Link to post
Share on other sites

Modeo 1.8 lx petrol
keeps cutting out when turning steering
at first on start up idol goes up and down then it cut out then start up again revs die and give it lots of revs keeps running
put it in garage they put a diagnostics on p1018
replaced map sensor
had a full service
oil change
all filters changed
spark plugs - coil pack - new leads
idol valve

Share this post


Link to post
Share on other sites

Hi Tony,

Rather than crossing threads, please feel free to create your own thread with your issue.

Share this post


Link to post
Share on other sites

You might have a injector thats slowly giving up. . If you get a code saying for example injector 1 above max threshold that's mean the injector has gone over the max amount of pulses that it's serviceable for

Sent from my C1905 using Ford OC mobile app

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now