Jump to content


Show
Photo
- - - - -

Ford Fiesta Water Trouble

water trouble

  • Please log in to reply
3 replies to this topic

#1 tirst

tirst

    Newbie

  • New Member
  • Pip
  • 7 posts
  • Ford Model: fiesta
  • Location: Newport

Posted 26 January 2013 - 06:38 PM

can anyone help me i,ve got a fiesta 52 plate duratec engine that starts and runs fine but as it gets up to temp water starts to come out of the water tank faster than it went in so my first thought was water pump or thermostat so changed the pump and took the stat out still the same flushed heater through and other pipes still no change engine dont over heat atall and dont seem to be mixing with oil thanks for taking the time to read my drama any help please

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 btmaldon

btmaldon

    Ford Enthusiast

  • FOC Supporters
  • 2,498 posts
  • Name: Bruce
  • Ford Model: BMW 320i Coupe M Sport
  • Year: 2008
  • Location: Essex

Posted 27 January 2013 - 07:36 PM

Sounds strange. Have you tried replacing the expansion tank cap? If its not holding the pressure the coolant could boil at a much lower temperature.

#3 fordpartsman

fordpartsman

    Area Rep: Midlands

  • Super Mod
  • 536 posts
  • Name: Adam
  • Ford Model: Fiesta MK7 Zetec S 1.6 Tdci
  • Year: 2010
  • Location: Northamptonshire

Posted 27 January 2013 - 09:28 PM

i know for a fact that we sell an awful lot of expansion tanks and also thermostat housings for these engines

have a look at these and see if there is any wet patches that indicate leaking

#4 tirst

tirst

    Newbie

  • New Member
  • Pip
  • 7 posts
  • Ford Model: fiesta
  • Location: Newport

Posted 28 January 2013 - 01:55 PM

no but will check these thanks for your help both :rolleyes:


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users