• Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


ken_i

Auxiliary Belts Or Water Pump

8 posts in this topic

Hi,

Can anyone help on this? Sometimes and not always on cold start I get a squealing from the engine bay which lasts bout 5-10 seconds. Having read a few forums it looks like it could be either auxiliary belts (?) or water pump, but being no mechanic I don't really have a clue.

Does anyone know of a reliable and a value for money mechanic in the Romford area that they would also recommend to sort out.

Thanks.

Share this post


Link to post
Share on other sites
 

Hello and welcome.

I had this on my 2001 focus even after replacing the belt but talcum powder would stop the noise. In the end I took some wire wool round the pulleys and problem solved.

Share this post


Link to post
Share on other sites

Cheers Stef,

I'll give that a go as soon as I've worked out how to get at the pulley's etc, they dont leave much room under the bonnet to work in do they?

Share this post


Link to post
Share on other sites

Cheers Stef,

I'll give that a go as soon as I've worked out how to get at the pulley's etc, they dont leave much room under the bonnet to work in do they?

Lol you dont get alot of space to work on anything these days, I repair boilers for a living and honestly its a nightmare to change the simplest wee part on some boilers lol

Share this post


Link to post
Share on other sites

what year is the car and what engine?

some things are getting to be a nightmare to work on these days with them cramming so much in

Share this post


Link to post
Share on other sites

It's a 2006, 2.0l auto estate and only go 40k on it, though rubber doesn't respect miles.

Having stubby fat fingers (according to wife anyway) doesn't help either repairing stuff (or on the wife either ;)

Share this post


Link to post
Share on other sites

It's a 2006, 2.0l auto estate and only go 40k on it, though rubber doesn't respect miles.

Having stubby fat fingers (according to wife anyway) doesn't help either repairing stuff (or on the wife either ;)

lmao :lol:

Share this post


Link to post
Share on other sites

agree with stef my mk1 did this and wire wool round the pulleys solved te issue for me also

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now