• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


VICKYH

Fiesta Zetec 56 Plate

5 posts in this topic

The carpet in the passenger footwell is soaking wet (I had an issue with water in the passenger door but that has been sorted by unblocking the holes along the seal at the bottom) but now the carpet is soaking wet near where the seat is but dry at the back around the console any advice would be gratefull.

I found out on the way home that water has started to collect in the door again, and that carpet is wetter could the to be linked ? I have released the water from the door again and am thinking maybe there should be another drain hole in the door at the frount?

Share this post


Link to post
Share on other sites
 

You may need to narrow it down with a hose pipe , could be window seal or entering from bulk head , start low and work your way up the car with a hose.

Share this post


Link to post
Share on other sites

Hi Preee,

Thanks for the advice, could the water in the door find its way to the passenger footwell or do you think I have two seperate issues?

Share this post


Link to post
Share on other sites

Hi I cant see any water coming through the windscreen when testing is it seems to be coming up from under the carpet (I put a mat on top and it is getting wet from underneath) are there any other possibilities or could it still be related to the water in the door?

Vicky

Share this post


Link to post
Share on other sites

I have been told by a local mechanic that the water was coming in from a section to the right of the fuse box near where all the wires run through to the engine but was right up high and out of site that wasn't sealed properly..

I hope this solves my issues and helps anyone else with the same problem.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now