Jump to content


Photo

escort diesel - non starter


  • Please log in to reply
4 replies to this topic

#1 drdre20013

drdre20013

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Escort TDC i
  • Location:

Posted 10 March 2009 - 07:29 AM

i have recently finished putting a new engine in my 99 escort diesel, it took me a little while but it went ok or so i thought, it seems there is not enough fuel getting into the engine for it to fire up, i have checked the pump and this seems ok and the feed and return pipes are fine, there are no leaks anywhere, any other ideas would be greatfully received.

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 vinnyvangough

vinnyvangough

    Ford Enthusiast

  • Moderator
  • 2,325 posts
  • Name: Steve
  • Ford Model: 2003 Focus TDCi, Escort Mk6 RS2000, Mk2
  • Year: 2003
  • Location: Devon

Posted 10 March 2009 - 11:45 AM

Is it a complete like-for-like swap or have you upgraded the engine to a newer/different lump?

#3 drdre20013

drdre20013

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Escort TDC i
  • Location:

Posted 10 March 2009 - 07:10 PM

its a straight swap for the same engine, i used the same loom so im stumped

#4 hotashel

hotashel

    Settling In Well

  • New Member
  • PipPipPip
  • 79 posts
  • Ford Model: mark 4 escort xr3i cabaret
  • Location:

Posted 10 March 2009 - 08:43 PM

Hi,

Have you changed the fuel pump or has it come off the engine that you have put it? Have you tried loosening the injectors to see how much fuel is coming through? If its got a different fuel pump you wont get the immobiliser to turn off. Have you used the manual pump to pump out the system of any air.

You could also try towing the car to see if it will start.
Sorry if you have tried all the above, but having recently done a engine on a pug we were stumped like you are when it would turn over but wouldnt run. We put the original fuel pump off the engine back on and hey presto much joy.
H

#5 Big T

Big T

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: Escort
  • Location:

Posted 12 March 2009 - 06:55 PM

Hi,

Im having the same problem with my 1995 1.8 van. It turns over, is getting diesel but it just wont start! I cannot prime the system as it dosent have a hand primer on the fuel filter! I cannot hear the glowplug relay clicking but I have turned the engine over untill the battery is flat so it should have started by then! Any ideas!!!!!!????????? :unsure:


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users