Jump to content


Photo

Mondeo Mk3 Problems

Engine Recon Idling problem

  • Please log in to reply
2 replies to this topic

#1 RonaldFord

RonaldFord

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: Mondeo Mk3
  • Location: Other / Non-UK

Posted 31 January 2013 - 01:47 PM

Hi All. Please help! I recently reconditioned my Duratec 2.0L Mondeo engine. The engine idles fine, revs fine, starts fine and even accelerates fine. However, whenever I depress the clutch at an intersection, the revs fall right down and the engine dies. It starts at the first swing again. Someone told me that the timing was out. I rechecked and reset it. Still the same problem. What else can I try? Thanks.

Have something to contribute?

Sign in or register to start a topic...

#2 BigD

BigD

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 619 posts
  • Name: -
  • Ford Model: -
  • Year: Non
  • Location: Other / Non-UK

Posted 31 January 2013 - 11:45 PM

Idle control valve would the likely culprit. Other possibilities; crankshaft sensor (hence somebody telling you the timing might be out), or lambda sensor.

#3 RonaldFord

RonaldFord

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: Mondeo Mk3
  • Location: Other / Non-UK

Posted 01 February 2013 - 04:45 AM

Thanks. I will check those.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users